Friday, September 06, 2013

Installing Facebook's Hiphop "Kimchi" Release on Centos 6.x , RHEL 6.x

Facebook's hiphop changelog is updated for "Kimchi" release in github with the following list.

"Kimchi" 2-Sep-2013
  - Fix order of custom attributes and visibility in ctor arg promotion
  - Implement CachingIterator
  - Implement RecursiveCachingIterator
  - Generalized heuristic for choosing when to inline in the jit
  - Imported calendar extension
  - Use gcc-4.8.1 by default
  - Improve hhvm commandline parsing logic
  - Fix register_shutdown in session_set_save_handler to match PHP 5.4
  - Add "native" functions for use in Systemlib
  - PHP extension source-compatitblility layer
  - Fix ArrayIterator constructor PHP compatibility
  - Enable building against libmemcached 1.0.8
  - Debugger: $_ not cleared but still printed after exception
  - Fix clone of SplPriorityQueue
  - Debugger: Fix bugs when multiple threads hit the same breakpoint
  - Fix several namespace bugs
  - Several PHP compatibility fixes for ArrayObject and ArrayIterator
  - Fix list assignment with collection literals
  - support "tuple(...)" in initializer expressions
  - HHVM should compile with libmemcached 1.0.9+
  - Support "(new Vector {..})->method()" style syntax
  - use trigger_error in PHP for Redis user errors
  - multiple simplexml fixes
  - fixed serialize/unserialize for SplObjectStorage
  - Implement ReflectionParameter::IsCallable()

I have pushed a new package to the repository, Grab the package and test it out.

Major change from packaging point of view is the libmemcached version, which is upgraded to 1.0.16

Follow these steps to upgrade

1. Enable repository as mentioned before

2. Do a yum upgrade (or yum install)

yum install hiphop-php- -y
Resolving Dependencies
--> Running transaction check
---> Package hiphop-php.x86_64 0:2.1.210-4.el6 will be updated
---> Package hiphop-php.x86_64 0: will be an update
--> Processing Dependency: libmemcached >= 1.0.9 for package: hiphop-php-
--> Processing Dependency: for package: hiphop-php-
--> Running transaction check
---> Package libmemcached.x86_64 0:0.49-1.el6 will be updated
---> Package libmemcached.x86_64 0:1.0.16-1.el6 will be an update
--> Finished Dependency Resolution

Dependencies Resolved

 Package              Arch           Version                 Repository    Size
 hiphop-php           x86_64         hop5          19 M
Updating for dependencies:
 libmemcached         x86_64         1.0.16-1.el6            hop5         208 k

Transaction Summary
Upgrade       2 Package(s)

Total download size: 19 M
Downloading Packages:
Total                                           777 kB/s |  19 MB     00:24     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating   : libmemcached-1.0.16-1.el6.x86_64                             1/4 
  Updating   : hiphop-php-                            2/4 
  Cleanup    : hiphop-php-2.1.210-4.el6.x86_64                              3/4 
  Cleanup    : libmemcached-0.49-1.el6.x86_64                               4/4 
  Verifying  : hiphop-php-                            1/4 
  Verifying  : libmemcached-1.0.16-1.el6.x86_64                             2/4 
  Verifying  : hiphop-php-2.1.210-4.el6.x86_64                              3/4 
  Verifying  : libmemcached-0.49-1.el6.x86_64                               4/4 

  hiphop-php.x86_64 0:                                           

Dependency Updated:
  libmemcached.x86_64 0:1.0.16-1.el6                                            

3. See that new package is installed

bash-4.1# rpm -qa | grep hiphop-php
4. Check the hhvm version details

bash-4.1# /usr/bin/hhvm --version
HipHop VM v2.1.0-dev (rel)
Compiler: heads/master-0-g13ddbb4ec17cffeeaaa83940016e6811cd71b387
Repo schema: a40e2fdb7f3c4700ef306f956630f09cd1ba53e0
bash-4.1# cd /var/www && /usr/bin/hhvm index.php 
Hello world.
5. Have fun!

NOTE: Please be aware that, from facebook's point of view this is just a internal release in the 2.1.0-dev series.


Post a Comment